Installer Xmind 8 sur Debian 10

Publié le 01 mai 2021 - Modifié le 08 mai 2021 | Classé dans : Configuration, Installation, Personnalisation, Intervention délicate en 10 min.
Mots clés : bureautique, Debian | Aucun commentaire

La difficulté vient du fait que la version 8 de Xmind nécessite des librairies Java qui ne font plus partie de Debian version 10. Il faut donc tordre un peu le cou d'apt pour installer ces librairies...

Au passage, à savoir qu'Xmind 8, dans sa version gratuite, n'exporte pas en pdf.

$ sudo vim /etc/apt/sources.list

deb http://security.debian.org/debian-security stretch/updates main
deb http://ftp.de.debian.org/debian stretch main

$ sudo apt-get update

$ cd ~bin/xmap08/

$ sudo ./setup.sh

$ sudo vim /etc/apt/sources.list

#deb http://security.debian.org/debian-security stretch/updates main
#deb http://ftp.de.debian.org/debian stretch main

$ vim XMind_amd64/XMind.ini

-vm
/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java
-configuration
./bin/xmind08/XMind_amd64/configuration
-data
./bin/xmind08/XMind_amd64/workspace
-startup
./bin/xmind08/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
./bin/xmind08/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160518-1444
--launcher.defaultAction
openFile
--launcher.GTK_version
2
-eclipse.keyring
@user.home/.xmind/secure_storage_linux
-vmargs
-Dfile.encoding=UTF-8

#à savoir : ./bin/xmind08 est à la racine du home user

$ ./bin/xmind08/XMind_amd64/XMind

Et ça marche

à voir également :

en 10 min. https://support.xmind.net/hc/en-us/community/posts/360056509232-Running-Xmind-8-update-9-on-Debian-Buster-10- Source : https://support.xmind.net/hc/en-us/community/posts/360056509232-Running-Xmind-8-update-9-on-Debian-Buster-10- coucou prevnext juste après coucou prevnext juste avant

Écrire un commentaire

Quelle est la deuxième lettre du mot 1akh7t0 ?

Fil RSS des commentaires de cet article